Graphics options disabled on high resolution.

  • Issue in-game

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Graphics options disabled on high resolution.

    When using HQ Engine my shadows, water and some other graphics options are disabled.
    Only above 1920x1080 tho.
    However my monitor is 2560x1080.
    I tried to modify settings file and making it "Read only" Did not work.
    Also when using windowed option it automatically removes those graphics features when going over 1920x1080.
    Gameforge updated version seems to allow those options and runs good.

    Must be 4.8 thing.

    Any ideas how to override this system? (allthethings)
  • My monitor has a larger resolution and no issues. Starting the client in windowed mode and changing the aspect ratio and size does not disable anything.
    Even setting it to fullscreen with 2560x1080 and above does not remove any of the options. Please make a screenshot of your graphics settings window, I'm curious how it looks.
  • When Window is smaller, then i can apply all details.
    When i stretch the window then quality goes low. (It does not refresh menu at first but ingame quality of shadows is changed instantly)
    When pressing apply (while maxed out) they go gray in menus too.
    • AA1.jpg

      684.27 kB, 2,560×1,080, viewed 21 times
    • AA2.jpg

      591 kB, 2,560×1,080, viewed 17 times
  • Don't know if this will help but I ran into a problem a while back with in game graphics and really went thru a lot of trying different things to figure out what was wrong, finally read a post that stated Windows had change graphics settings when it did an update, I checked mine and sure enough it had lowered them.
  • I've never seen this before, not even heard about it. But I found a thread on reddit where someone had the same problem. Unfortunately no solution: Game Client locking certain graphical settings. : aion

    What graphics card do you have? I suppose it only affects systems with graphics cards below a certain performance level, even if it's powerful enough for Aion at max settings.
    Maybe with a bit of luck a driver update could help, but I doubt it.
  • GTX 1060 6GB
    I tought it could be some issue with my hardware but official Aion (6.0 or whatever it is atm) on steam, runs perfectly when all maxed out.

    so it should be Aion version problem. However if you say that it runs all maxed on ultra wide for you.... Then i have no idea.

    Extra question: Is it possible to add SweetFX.
    For some reason it wont find right Aion.exe.

    Im pretty sure that "HD graphics" in aion are not much more than tweaks in SweetFX so this would be great solution too.
    (Cant get same results but something something)
  • With that graphics card the client definitely should not limit any settings. Just a wild guess, but you can try to run the game from C:/ and not D:/ like it shows on your screenshots.
    If that's an external HDD, the client may think it can limit certain settings to speed up dynamic loading. But that still wouldn't explain why shadows or effects are also disabled. I would expect texture details or object range to be limited instead but still it's worth a try.

    And from what I've read about SweetFX, it's just a post-processor. So it actually cannot replicate the settings that the client disables. The only thing that may be interesting is the SMAA feature since Aion doesn't support anti-aliasing on the high quality renderer. Not sure if it's still available on the old standard renderer. But SMAA may make the image muddy because it applies to the already rendered image like any post-processing step does.
    I have no idea if and how you can set it up with Aion, but it's not forbidden by our ToS so you can try.
  • This might actually work. Doesn't look too far off, even though the kind of workaround that is used looks funky. But it isn't compatible with our client out of the box.
    I will take a deeper look at it and adapt it for our version once verified that it runs without issues or side effects.
    So please be patient, this may take a while. Since I don't have the issue on my client, I may contact you for beta testing. If successful we can update our patcher afterwards.
  • I just found out that I have the same issue like you once I set my game resolution to exactly the monitor resolution. Usually I use windowed mode at a lower width than my monitor. So I just didn't test full size, otherwise I would have run into the same issues like you. That means it doesn't depend on a specific resolution like I thought before. It's a problem that seems to affect any larger resolution once it matches the monitors resolution, pretty weird.
    But the good side is that I can test the fix myself, which makes everything easier and also a bit faster.
    I assume for now you can play in windowed mode at 2559x1080 and should be fine. At least for me all options are available if the window is slightly smaller than native resolution.
  • For me it disables settings after window is bigger than 7/8 of the screen.
    So it should be something like 2240x1080. (Not very accurate, since i used fingers to measure the screen)

    Its good to hear that you can test it and can benefit from the fix yourself. More motivation :D
    However windowed mode is mostly "No No" for me, unless crafting or semi afk. // not sure if this is a valid thing: Semi afk :D
    I hate this white window line etc. (enrage)
  • We updated our patcher which will resolve this limitation. Although resizing your window while the settings are open may disable the sliders. In this case you need to close and re-open the settings and they should be active again.
  • Share